Tcl DBus Interface

Check-in [6da4a0f17a]
Login

Many hyperlinks are disabled.
Use anonymous login to enable hyperlinks.

Overview
Comment:Add missed dbus version number to the manual page.
Downloads: Tarball | ZIP archive | SQL archive
Timelines: family | ancestors | descendants | both | trunk | master | release-1-4
Files: files | file ages | folders
SHA3-256:6da4a0f17ac57fd03ad0219ee4d0521788d3590aa2cae4fd74eb088deb9dc28e
User & Date: schelte 2018-09-28 09:47:35
Context
2019-01-12
16:09
With version 3.0 of the dbus library, the module doesn't need to handle multiple interps on the same connection anymore. This removes an argument from some commands. For that reason the major version number has been incremented. check-in: d409275cf0 user: schelte tags: trunk, master
2018-09-28
09:47
Add missed dbus version number to the manual page. check-in: 6da4a0f17a user: schelte tags: trunk, master, release-1-4
09:42
- Version 1.4 - Accept both version 2.1+ and 3.0+ of the dbus library. check-in: 18f295af66 user: schelte tags: trunk, master
Changes
Hide Diffs Unified Diffs Ignore Whitespace Patch

Changes to doc/dbif.man.

3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
[vset cmdname dbif]
[vset version 1.4]
[manpage_begin [vset libname] n [vset version]]
[copyright {2008-2017 Schelte Bron}]
[moddesc {Tcl D-Bus Interface}]
[titledesc {Application layer around the Tcl D-Bus library}]
[require Tcl 8.5]
[require dbus "2.1"]
[require [vset libname] [vset version]]
[description]

The [package [vset libname]] package provides a higher level wrapper around
the low-level D-Bus commands provided by the dbus package. The package also
provides an implementation of a number of standard D-Bus interfaces.
See [sectref "STANDARD INTERFACES"] for more information.







|







3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
[vset cmdname dbif]
[vset version 1.4]
[manpage_begin [vset libname] n [vset version]]
[copyright {2008-2017 Schelte Bron}]
[moddesc {Tcl D-Bus Interface}]
[titledesc {Application layer around the Tcl D-Bus library}]
[require Tcl 8.5]
[require dbus "2.1 3.0"]
[require [vset libname] [vset version]]
[description]

The [package [vset libname]] package provides a higher level wrapper around
the low-level D-Bus commands provided by the dbus package. The package also
provides an implementation of a number of standard D-Bus interfaces.
See [sectref "STANDARD INTERFACES"] for more information.